Last Call for API Modifications
I'm finalizing the Ultra App Kit API, which is going to be the basis of the new engine's API. Naming commands themselves is always a bit of an art unto itself. Some things are named a certain way because it is common convention, like Stream::Seek() instead of Stream::SetPosition() and ACos() instead of ArcCosine().
Other times we have holdovers from old APIs or BASIC syntax like Stream::EOF() or String::Mid().
Should a class that has no SetSize() method use GetSize() or Size() for a method that returns the size? I have to decide these things now and live with the repercussions for years.
Take a look through the new documentation and tell me if you have any suggestions, or forever hold your peace.
- 2
8 Comments
Recommended Comments